archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libieee1284 / repos / extra-x86_64 / PKGBUILD
blob2237e4dca92e974ae0f4a2580630b85dc9151407
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Manolis Tzanidakis <manolis@archlinux.org>
4 pkgname=libieee1284
5 pkgver=0.2.11
6 _tag=${pkgver//\./_}
7 pkgrel=11
8 pkgdesc="A library to query devices connected in parallel port"
9 arch=('x86_64')
10 license=('GPL2')
11 url="https://github.com/twaugh/libieee1284"
12 optdepends=('python: for python module')
13 makedepends=('python' 'xmlto' 'docbook-xml' 'docbook-xsl')
14 source=(libieee1284-$pkgver.zip::https://github.com/twaugh/libieee1284/archive/V$_tag.zip
15         upstream_python_fix1.patch
16         upstream_python_fix2.patch
17         python3.patch)
18 sha1sums=('5e24fb4e69652e2460e24af0b7ef6ca960c78965'
19           '8492a99b3350d0201c8720acda8ef442c36c651d'
20           '01dc3aed6266db00e1d0b9c3f6c15aabfdcdcf14'
21           '55f92727e761afd3640edae01b6087eb4779ea0b')
23 prepare() {
24   cd $pkgname-$_tag
26   patch -p1 < ../upstream_python_fix1.patch # https://github.com/twaugh/libieee1284/commit/c48855528beee1397d883f9c8a5df7aed5c917a6
27   patch -p1 < ../upstream_python_fix2.patch # https://github.com/twaugh/libieee1284/commit/b4d63327dfef8dbf12aabf4bba0f6818a3519995
29   patch -p1 < ../python3.patch # https://github.com/twaugh/libieee1284/issues/4
32 build() {
33   cd $pkgname-$_tag
35   ./bootstrap
36   ./configure --prefix=/usr --mandir=/usr/share/man --with-python
37   make
40 package() {
41   cd $pkgname-$_tag
42   make DESTDIR="$pkgdir"/ install