archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libmp4v2 / trunk / PKGBUILD
blob189bce40f66afbd6d72171e991601eb5c1cfacb3
1 # Maintainer: Tom Gundersen <teg@jklm.no>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=libmp4v2
6 pkgver=5.0.1
7 pkgrel=1
8 pkgdesc="An API to create and modify mp4 files as defined by ISO-IEC:14496-1:2001 MPEG-4 Systems"
9 arch=('x86_64')
10 license=('MPL')
11 url="https://github.com/TechSmith/mp4v2"
12 depends=('gcc-libs')
13 source=("https://github.com/TechSmith/mp4v2/archive/Release-ThirdParty-MP4v2-$pkgver.tar.gz")
14 sha512sums=('662b85e2d5cd1c190e7cbc7074914f750939694f8391ebf1402ecb90c533a35acc5bb5a1cfa852fc06e39c0b7e92142d26f8ee94fa2e6df2c0b1ed94fc2c63d7')
16 build() {
17   cd mp4v2-Release-ThirdParty-MP4v2-$pkgver
19   # https://github.com/TechSmith/mp4v2/issues/48
20   CXXFLAGS="$CXXFLAGS -Wno-narrowing" ./configure --prefix=/usr
21   make
24 package() {
25   cd mp4v2-Release-ThirdParty-MP4v2-$pkgver
26   make DESTDIR="$pkgdir" install
27   make DESTDIR="$pkgdir" install-man