archrelease: copy trunk to extra-x86_64
[arch-packages.git] / meld / repos / testing-any / PKGBUILD
blobbe52376a55fe1ffb1f7ba37d0cd509a59a967f1e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
4 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
6 pkgname=meld
7 pkgver=3.20.4
8 pkgrel=2
9 pkgdesc="Compare files, directories and working copies"
10 url="https://meldmerge.org/"
11 license=(GPL)
12 arch=(any)
13 depends=(python-gobject python-cairo gtksourceview3 gsettings-desktop-schemas dconf)
14 makedepends=(intltool yelp-tools git)
15 _commit=b3810b9407263adc1cb6bbd83448794b9e9957b2  # tags/3.20.4^0
16 source=("git+https://gitlab.gnome.org/GNOME/meld.git#commit=$_commit")
17 sha1sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   cd $pkgname
30   python setup.py build
33 package() {
34   cd $pkgname
35   # using --skip-build breaks install
36   python setup.py --no-update-icon-cache --no-compile-schemas \
37     install --prefix=/usr --root="$pkgdir" --optimize=1