1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
6 pkgname=('mtr' 'mtr-gtk')
9 pkgdesc='Combines the functionality of traceroute and ping into one tool'
10 url='https://www.bitwizard.nl/mtr/'
13 makedepends=('ncurses' 'gtk2' 'libcap')
15 source=(https://github.com/traviscross/mtr/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha512sums=('0e58bd79562ff80f9308135562ab22aa1f1eea686aefd3aef07bac05e661e34b60fde7c66c96bf4f0919f546376fbd6106ecd8fa92328c24f6f903097496bf11')
17 b2sums=('e9b4619a85a515d729f0987d5882fb91e4bfa3be82476efbfdb832d0b13ed334be1c1a1bcf8ab4ca820002e79ca4a24d0b50f2739d9284b7dec0b8852a1a91e0')
20 (cd ${pkgbase}-${pkgver}
21 echo "${pkgver}" > .tarball-version
24 cp -ra ${pkgbase}-${pkgver}{,-cli}
28 (cd ${pkgbase}-${pkgver}-cli
35 (cd ${pkgbase}-${pkgver}
44 pkgdesc='Combines the functionality of traceroute and ping into one tool (CLI version)'
45 depends=('ncurses' 'libcap')
46 optdepends=('bash-completion: bash completion support')
47 cd ${pkgbase}-${pkgver}-cli
48 make DESTDIR="${pkgdir}" install
52 pkgdesc='Combines the functionality of traceroute and ping into one tool (GTK version)'
53 depends=('ncurses' 'libcap' 'gtk2')
54 optdepends=('bash-completion: bash completion support')
56 provides=("mtr=${pkgver}")
57 cd ${pkgbase}-${pkgver}
58 make DESTDIR="${pkgdir}" install