archrelease: copy trunk to extra-x86_64
[arch-packages.git] / nss_ldap / trunk / PKGBUILD
blobaa872efbfe7c0069801361e81bd1c4cd558751e2
1 # Maintainer:
2 # Contributor: Comete <la_comete@tiscali.fr>
4 pkgname=nss_ldap
5 pkgver=265
6 pkgrel=9
7 pkgdesc="The nss_ldap module provides the means for Linux and Solaris workstations to resolve the entities defined in RFC 2307 from LDAP directories."
8 arch=('x86_64')
9 url="http://www.padl.com/OSS/nss_ldap.html"
10 license=('LGPL')
11 depends=('libldap' 'krb5')
12 backup=("etc/nss_ldap.conf")
13 source=("https://fossies.org/linux/privat/old/${pkgname}-${pkgver}.tar.gz"
14         "https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/6a27f55c8370f8b49fd3c10d46214de9c9c37932/extra/nss_ldap/nss_ldap-265-glibc-2.16.patch"
15         "https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/6a27f55c8370f8b49fd3c10d46214de9c9c37932/extra/nss_ldap/nss_ldap-265-pthread.patch"
16         "reproducible-build.patch")
17 md5sums=('c1cb02d1a85538cf16bca6f6a562abe4'
18          '49df78dc482f90f5c3d850a664308216'
19          '38c881edcb8df6b426f8a9d8f269d567'
20          'fd05b8e76fe16a3ac54bffe58db57ff1')
21 b2sums=('31b233ef7680204abfb62408141609b9489e133327c787c59afedd9ac41194189bde26d1f3b0a885622f57ec769ddee2bdf7d274b9584d4d5002d1c016c86892'
22         'f736842ef193d863c80349cacd2dfc6991e4e92d5e2205f2f40767a9786b86b0fa4b06d671dd17d93e7c7a8da65c2a7d3111914480d7a9cf308a9c2f37753b89'
23         'ff732b836d4405041337f653cc3f8d4645704d94023285cd31af58739331459337fb66c1928ff3a4b42b3aed29ffa95e0408734ab5e18b67c4f86ce84b5362af'
24         'da2f5b2a35c723acf464a6ec85a1658799e5fcdc898645f57224a50848287a7716b9e02fbaa731838417d1e54f8322f9748d83e324f997bbf737c215cbd42c6e')
26 prepare() {
27   cd "${srcdir}/${pkgname}-${pkgver}"
29   # FS#41068 
30   patch -p0 -i ../nss_ldap-265-glibc-2.16.patch
31   patch -p0 -i ../nss_ldap-265-pthread.patch
33   # reproducible builds
34   patch -p1 -i ../reproducible-build.patch
37 build() {
38   cd "${srcdir}/${pkgname}-${pkgver}"
40   export PERL5LIB="$PWD"
41   ./configure \
42        --prefix=/usr \
43        --with-ldap-conf-file=/etc/nss_ldap.conf \
44        --with-ldap=openldap \
45        --sysconfdir=/etc \
46        --mandir=/usr/share/man \
47        --enable-schema-mapping \
48        --enable-rfc2307bis \
49        --enable-configurable-krb5-ccname-gssapi
50   env PATH=`pwd`:"$PATH" make
53 package() {
54   cd "${srcdir}/${pkgname}-${pkgver}"
55   make DESTDIR="${pkgdir}" install
57   # buildsystem is trying to be clever and hardcodes symlinks in /usr$(libdir)
58   rm -rf "${pkgdir}/usr/usr"