archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-cairo / trunk / PKGBUILD
blob1d4060aa4d36659a85505f0792142fb61fbdf27f
1 # Maintainer: Angel Velasquez <angvp@archlinux.org>  
2 # Maintainer: Jan de Groot <jgc@archlinux.org>
4 pkgname=python-cairo
5 pkgver=1.20.1
6 pkgrel=3
7 pkgdesc="Python bindings for the cairo graphics library"
8 arch=('x86_64')
9 url="https://pycairo.readthedocs.io/en/latest/"
10 license=('LGPL2.1' 'MPL')
11 depends=(cairo python)
12 makedepends=(git)
13 _commit=320b22711fcc55b0158c156e2aab19a2df0c2898
14 source=("git+https://github.com/pygobject/pycairo/#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd pycairo
19   git describe --tags | sed 's/^v//;s/-/+/g'
22 build() {
23   cd pycairo
24   python setup.py build
27 package() {
28   cd pycairo
29   python setup.py install --skip-build --root="${pkgdir}" --optimize='1'