archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-base / trunk / PKGBUILD
blobb55b603e9871171b8945a67dbfd32dc9fa188e2f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgbase=qt5-base
5 pkgname=(qt5-base qt5-xcb-private-headers)
6 pkgver=5.15.2+kde+r263
7 pkgrel=1
8 _commit=7c6c0030cf80ef7b9ace42996b0e0c3a72f76860
9 arch=('x86_64')
10 url='https://www.qt.io'
11 license=('GPL3' 'LGPL3' 'FDL' 'custom')
12 pkgdesc='A cross-platform application and UI framework'
13 depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
14          'shared-mime-info' 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'mesa'
15          'tslib' 'libinput' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion' 'md4c')
16 makedepends=('libfbclient' 'mariadb-libs' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
17              'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers' 'git')
18 optdepends=('qt5-svg: to use SVG icon themes'
19             'qt5-wayland: to run Qt applications in a Wayland session'
20             'qt5-translations: for some native UI translations'
21             'postgresql-libs: PostgreSQL driver'
22             'mariadb-libs: MariaDB driver'
23             'unixodbc: ODBC driver'
24             'libfbclient: Firebird/iBase driver'
25             'freetds: MS SQL driver'
26             'gtk3: GTK platform plugin'
27             'perl: for fixqt4headers and syncqt')
28 conflicts=('qtchooser')
29 groups=('qt' 'qt5')
30 _pkgfqn=qtbase
31 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
32         qt5-base-cflags.patch
33         qt5-base-nostrip.patch)
34 sha256sums=('SKIP'
35             'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
36             '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
38 pkgver() {
39   cd $_pkgfqn
40   echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
43 prepare() {
44   cd ${_pkgfqn}
46   git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
48   patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
49   patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
52 build() {
53   cd ${_pkgfqn}
55   ./configure -confirm-license -opensource -v \
56     -prefix /usr \
57     -docdir /usr/share/doc/qt \
58     -headerdir /usr/include/qt \
59     -archdatadir /usr/lib/qt \
60     -datadir /usr/share/qt \
61     -sysconfdir /etc/xdg \
62     -examplesdir /usr/share/doc/qt/examples \
63     -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
64     -system-sqlite \
65     -openssl-linked \
66     -nomake examples \
67     -no-rpath \
68     -dbus-linked \
69     -system-harfbuzz \
70     -journald \
71     -no-mimetype-database \
72     -no-use-gold-linker \
73     -reduce-relocations \
74     -no-strip
75   make
78 package_qt5-base() {
79   pkgdesc='A cross-platform application and UI framework'
81   cd ${_pkgfqn}
82   make INSTALL_ROOT="${pkgdir}" install
84   install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
86   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
87   find "${pkgdir}/usr/lib" -type f -name '*.prl' \
88     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
90   # Fix wrong qmake path in pri file
91   sed -i "s|${srcdir}/${_pkgfqn}|/usr|" \
92     "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
94   # Symlinks for backwards compatibility
95   for b in "${pkgdir}"/usr/bin/*; do
96     ln -s $(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
97   done
100 package_qt5-xcb-private-headers() {
101   pkgdesc='Private headers for Qt5 Xcb'
103   depends=("qt5-base=$pkgver")
104   optdepends=()
105   groups=()
106   conflicts=()
108   cd ${_pkgfqn}
109   install -d -m755 "$pkgdir"/usr/include/qtxcb-private
110   cp -r src/plugins/platforms/xcb/*.h "$pkgdir"/usr/include/qtxcb-private/