1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=qt5-connectivity
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Provides access to Bluetooth hardware'
12 depends=('qt5-base' 'bluez-libs')
13 makedepends=('qt5-declarative')
14 optdepends=('qt5-declarative: QML bindings')
16 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
17 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
18 sha256sums=('0380327871f76103e5b8c2a305988d76d352b6a982b3e7b3bc3cdc184c64bfa0')
33 make INSTALL_ROOT="$pkgdir" install
35 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
36 find "$pkgdir/usr/lib" -type f -name '*.prl' \
37 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
39 install -d "$pkgdir"/usr/share/licenses
40 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}