archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-scxml / repos / extra-x86_64 / PKGBUILD
blob92af0526ad395a920e0c1814691c3fc6f4150c72
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=qt5-scxml
5 _qtver=5.15.2
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=('x86_64')
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Static and runtime integration of SCXML models into Qt code'
12 depends=('qt5-declarative')
13 makedepends=()
14 groups=('qt' 'qt5')
15 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
16 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
17 sha256sums=('60b9590b9a41c60cee7b8a8c8410ee4625f0389c1ff8d79883ec5a985638a7dc')
19 prepare() {
20   mkdir -p build
23 build() {
24   cd build
26   qmake ../${_pkgfqn}
27   make
30 package() {
31   cd build
32   make INSTALL_ROOT="$pkgdir" install
34   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
35   find "$pkgdir/usr/lib" -type f -name '*.prl' \
36     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
38   install -d "$pkgdir"/usr/share/licenses
39   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}