archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt5-serialport / trunk / PKGBUILD
blob5d60f3ec45ab7d721d05988c1df50674bd21812d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
4 pkgname=qt5-serialport
5 _qtver=5.15.2
6 pkgver=${_qtver/-/}
7 pkgrel=1
8 arch=('x86_64')
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Provides access to hardware and virtual serial ports'
12 depends=('qt5-base')
13 makedepends=()
14 groups=('qt' 'qt5')
15 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
16 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
17 sha256sums=('59c559d748417306bc1b2cf2315c1e63eed011ace38ad92946af71f23e2ef79d')
19 prepare() {
20   mkdir -p build
23 build() {
24   cd build
26   qmake ../${_pkgfqn}
27   make
30 package() {
31   cd build
32   make INSTALL_ROOT="$pkgdir" install
34   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
35   find "$pkgdir/usr/lib" -type f -name '*.prl' \
36     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
38   install -d "$pkgdir"/usr/share/licenses
39   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}