1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
9 url='https://www.qt.io'
10 license=('GPL3' 'LGPL3' 'FDL' 'custom')
11 pkgdesc='Provides a way to display web content in a QML application'
12 depends=('qt5-webengine')
15 _pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
16 source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
17 sha256sums=('be9f46167e4977ead5ef5ecf883fdb812a4120f2436383583792f65557e481e7')
32 make INSTALL_ROOT="$pkgdir" install
34 # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
35 find "$pkgdir/usr/lib" -type f -name '*.prl' \
36 -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
38 install -d "$pkgdir"/usr/share/licenses
39 ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}