archrelease: copy trunk to extra-x86_64
[arch-packages.git] / qt6-5compat / repos / extra-x86_64 / PKGBUILD
blob43180a4cb5b4b753e610e26dc115db5aeef0debe
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=qt6-5compat
6 _qtver=6.2.2
7 pkgver=${_qtver/-/}
8 pkgrel=1
9 arch=(x86_64)
10 url='https://www.qt.io'
11 license=(GPL3 LGPL3 FDL custom)
12 pkgdesc='Module that contains unsupported Qt 5 APIs'
13 depends=(qt6-base)
14 makedepends=(cmake ninja qt6-declarative)
15 optdepends=('qt6-declarative: for QtGraphicalEffects')
16 groups=(qt6)
17 _pkgfn="${pkgname/6-/}-everywhere-src-$_qtver"
18 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('a5bb33d9df1d99e5afc21b0d0a36b79aa98829e2b1bee03c811ad69b79276bad')
21 build() {
22   cmake -B build -S $_pkgfn -G Ninja
23   cmake --build build
26 package() {
27   DESTDIR="$pkgdir" cmake --install build
29   install -d "$pkgdir"/usr/share/licenses
30   ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname