1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 # Contributor: Geoffroy Carrier <geoffroy.carrier@aur.archlinux.org>
4 # Contributor: Eric Belanger <belanger@astro.umontreal.ca>
5 # Contributor: aeolist <aeolist@hotmail.com>
6 # Contributor: Gabriel Rauter <rauter.gabriel@gmail.com>
11 pkgdesc="Kernel based performance profiler"
12 url="https://wiki.gnome.org/Apps/Sysprof"
15 depends=(gtk3 polkit libdazzle)
16 makedepends=(yelp-tools git meson)
18 _commit=2903f08d02c86e520b07c0df5dcafc18bb8ef059 # tags/3.42.1^0
19 source=("git+https://gitlab.gnome.org/GNOME/sysprof.git#commit=$_commit")
23 makedepends+=("gcc>=$_gccver" "gcc<$((_gccver + 1))")
24 conflicts+=("gcc<$_gccver" "gcc>=$((_gccver + 1))")
28 git describe --tags | sed 's/^sysprof-//;s/-/+/g'
36 # Ensure static library is non-LTO compatible
37 CFLAGS+=" -ffat-lto-objects"
39 arch-meson $pkgname build
40 meson compile -C build
44 meson test -C build --print-errorlogs
48 meson install -C build --destdir "$pkgdir"