archrelease: copy trunk to extra-x86_64
[arch-packages.git] / tali / trunk / PKGBUILD
blob124beb78ad3ff101e1dd812d68092a7c16ec60d5
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=tali
5 pkgver=40.4
6 pkgrel=1
7 pkgdesc="Beat the odds in a poker-style dice game"
8 url="https://wiki.gnome.org/Apps/Tali"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(meson gobject-introspection yelp-tools appstream-glib git)
13 groups=(gnome-extra)
14 _commit=5bd76c59bb58d669ffcfeddd47895cbd9483bc06  # tags/40.4^0
15 source=("git+https://gitlab.gnome.org/GNOME/tali.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"