archrelease: copy trunk to extra-x86_64
[arch-packages.git] / vc / trunk / PKGBUILD
blobb71cb5dcde2c29879d60fca4b37c9f7b9c292409
1 # Maintainer:
2 # Contributor: Andrea Scarpino <andrea@archlinux.org>
3 # Contributor: PedsXing <pedsxing at gmx dot net>
5 pkgname=vc
6 pkgver=1.4.2
7 pkgrel=1
8 pkgdesc='A library to ease explicit vectorization of C++ code'
9 url='https://github.com/VcDevel/Vc'
10 arch=(x86_64)
11 license=(LGPL3)
12 makedepends=(cmake)
13 source=(https://github.com/VcDevel/Vc/releases/download/$pkgver/Vc-$pkgver.tar.gz)
14 sha256sums=('50d3f151e40b0718666935aa71d299d6370fafa67411f0a9e249fbce3e6e3952')
16 build() {
17   cmake -B build -S Vc-$pkgver \
18     -DCMAKE_INSTALL_PREFIX=/usr \
19     -DTARGET_ARCHITECTURE=generic
20   cmake --build build
23 package() {
24   DESTDIR="$pkgdir" cmake --install build