archrelease: copy trunk to extra-x86_64
[arch-packages.git] / xdg-desktop-portal / trunk / PKGBUILD
blob8ddd89c6e5f98945fad1ed16249fe2f55bec00d0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Patrick Griffis <tingping@tingping.se>
5 pkgname=xdg-desktop-portal
6 pkgver=1.10.1
7 pkgrel=1
8 pkgdesc="Desktop integration portals for sandboxed apps"
9 url="https://github.com/flatpak/xdg-desktop-portal"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glib2 pipewire fuse2 geoclue2)
13 makedepends=(python xmlto docbook-xsl git flatpak libportal)
14 checkdepends=(epiphany gedit gvfs)
15 _commit=7dccf42892fdfcc9c3542cad3afdf45351edb63e  # tags/1.10.1^0
16 source=("git+https://github.com/flatpak/xdg-desktop-portal#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
26   NOCONFIGURE=1 ./autogen.sh
29 build() {
30   cd $pkgname
31   ./configure --prefix=/usr --libexecdir=/usr/lib
32   make 
35 check() {
36   cd $pkgname
37   make check
40 package() {
41   depends+=(xdg-desktop-portal-impl)
43   cd $pkgname
44   make DESTDIR="$pkgdir" install