upgpkg: sbcl 2.2.9-1
[arch-packages.git] / at-spi2-core / trunk / PKGBUILD
blob16b0ce51553278dad1adf299eacfd571300e57ff
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgbase=at-spi2-core
5 pkgname=(at-spi2-core at-spi2-core-docs)
6 pkgver=2.46.0
7 pkgrel=2
8 pkgdesc="Protocol definitions and daemon for D-Bus at-spi"
9 url="https://gitlab.gnome.org/GNOME/at-spi2-core"
10 arch=(x86_64)
11 license=(GPL2)
12 depends=(
13   dbus
14   glib2
15   libx11
16   libxml2
17   libxtst
18   systemd
20 makedepends=(
21   dbus-broker
22   git
23   gobject-introspection
24   gtk-doc
25   meson
27 options=(debug)
28 _commit=97d9ba04e19d0a9edd209d97db81eb6ede5fe4d6  # tags/AT_SPI2_CORE_2_46_0^0
29 source=("git+https://gitlab.gnome.org/GNOME/at-spi2-core.git#commit=$_commit")
30 sha256sums=('SKIP')
32 pkgver() {
33   cd at-spi2-core
34   git describe --tags | sed 's/^AT_SPI2_CORE_//;s/_/./g;s/-/+/g'
37 prepare() {
38   cd at-spi2-core
41 build() {
42   local meson_options=(
43     -D default_bus=dbus-broker
44     -D docs=true
45   )
47   arch-meson at-spi2-core build "${meson_options[@]}"
48   meson compile -C build
51 check() {
52   # memory test fails without desktop
53   # broker fails to launch without journald
54   dbus-run-session meson test -C build --print-errorlogs || :
57 package_at-spi2-core() {
58   optdepends=('dbus-broker: Alternative bus implementation')
59   provides=(
60     "at-spi2-atk=$pkgver-$pkgrel"
61     "atk=$pkgver-$pkgrel"
62     libatk-1.0.so
63     libatk-bridge-2.0.so
64     libatspi.so
65   )
66   conflicts=(
67     'at-spi2-atk<=2.38.0-2'
68     'atk<=2.38.0-2'
69   )
70   replaces=(
71     'at-spi2-atk<=2.38.0-2'
72     'atk<=2.38.0-2'
73   )
75   meson install -C build --destdir "$pkgdir"
77   mkdir -p doc/usr/share
78   mv {"$pkgdir",doc}/usr/share/gtk-doc
81 package_at-spi2-core-docs() {
82   pkgdesc+=" (documentation)"
83   depends=()
85   mv doc/* "$pkgdir"
88 # vim:set sw=2 sts=-1 et: