3.89.1-1
[arch-packages.git] / fontforge / trunk / PKGBUILD
blob3ae999eaf16e7bbd276ba8e8fb3538661a533184
1 # Maintainer: Gaetan Bisson <bisson@archlinux.org>
2 # Contributor: Eric Belanger <eric@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=fontforge
6 pkgver=20230101
7 pkgrel=3
8 pkgdesc='Outline and bitmap font editor'
9 url='https://fontforge.github.io/'
10 arch=('x86_64')
11 license=('BSD')
12 makedepends=('cmake' 'git' 'python-sphinx')
13 depends=('libtool' 'pango' 'giflib' 'libtiff' 'libxml2' 'libspiro' 'python'
14          'potrace' 'woff2' 'gtk3' 'libuninameslist')
15 source=("https://github.com/${pkgname}/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.xz"
16         fontforge-doc-no-warn-error.patch)
17 sha256sums=('ca82ec4c060c4dda70ace5478a41b5e7b95eb035fe1c4cf85c48f996d35c60f8'
18             'b87fa5a39d6948262d2dfb9b84c2462dc21de0bfb115cdd13e893c1b533d8f78')
20 prepare() {
21         cd "${srcdir}/${pkgname}-${pkgver}"
22         mkdir build
23         patch -Np1 -i ../fontforge-doc-no-warn-error.patch
26 build() {
27         cd "${srcdir}/${pkgname}-${pkgver}/build"
28         cmake \
29                 -DCMAKE_BUILD_TYPE=Release \
30                 -DCMAKE_INSTALL_PREFIX=/usr \
31                 -DENABLE_MAINTAINER_TOOLS=TRUE \
32                 -DENABLE_FONTFORGE_EXTRAS=TRUE \
33                 -DUNIX=TRUE \
34                 ..
36         make
39 package() {
40         cd "${srcdir}/${pkgname}-${pkgver}"
41         cd build
42         make DESTDIR="${pkgdir}" install
43         install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"