1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
7 pkgdesc="Spell checker and morphological analyzer library and program"
9 url="https://github.com/hunspell/hunspell"
10 license=('GPL' 'LGPL' 'MPL')
11 depends=('gcc-libs' 'readline')
12 optdepends=('perl: for ispellaff2myspell')
13 source=(https://github.com/hunspell/hunspell/releases/download/v${pkgver}/hunspell-${pkgver}.tar.gz)
14 sha256sums=('11ddfa39afe28c28539fe65fc4f1592d410c1e9b6dd7d8a91ca25d85e9ec65b8')
18 ./configure --prefix=/usr \
22 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33 make DESTDIR="$pkgdir" install
35 # add generic hunspell.so for development and projects not using pkgconfig flags - FS#30592
36 pushd "$pkgdir"/usr/lib
37 ln -s libhunspell-?.?.so libhunspell.so