2 # Contributor: Solomon Choina <shlomochoina@gmail.com>
7 _commit=fda9f4b3db97ccb243fcbed2ce280eb4135d705b
8 pkgdesc='uTorrent Transport Protocol library'
9 url='https://github.com/bittorrent/libutp'
10 makedepends=(git cmake)
13 license=('custom:Public Domain')
14 source=(git+https://github.com/transmission/libutp.git#commit=$_commit)
19 printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
23 cmake -B build -S libutp \
24 -DCMAKE_INSTALL_PREFIX=/usr \
25 -DLIBUTP_BUILD_PROGRAMS=OFF \
26 -DCMAKE_CXX_FLAGS="$CXXFLAGS -ffat-lto-objects"
31 DESTDIR="$pkgdir" cmake --install build
32 install -Dm644 libutp/LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname