3.89.1-1
[arch-packages.git] / speexdsp / trunk / PKGBUILD
blobf789c51c31846d83783a0c31568dd01dc7994c9e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=speexdsp
4 pkgver=1.2.1
5 pkgrel=1
6 pkgdesc="DSP library derived from Speex"
7 url="https://www.speex.org/"
8 arch=(x86_64)
9 license=(BSD)
10 depends=(gcc-libs)
11 makedepends=(git)
12 provides=(libspeexdsp.so)
13 _commit=1b28a0f61bc31162979e1f26f3981fc3637095c8  # tags/SpeexDSP-1.2.1^0
14 source=("git+https://gitlab.xiph.org/xiph/speexdsp.git#commit=$_commit")
15 b2sums=('SKIP')
17 pkgver() {
18   cd speexdsp
19   git describe --tags | sed 's/^SpeexDSP-//;s/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd speexdsp
24   ./autogen.sh
27 build() {
28   cd speexdsp
29   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
30     --disable-static
31   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32   make
35 check() {
36   cd speexdsp
37   make -k check
40 package() {
41   cd speexdsp
42   make DESTDIR="$pkgdir" install
43   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING