1 # Maintainer: Laurent Carlier <lordheavym@gmail.com>
2 # Contributor: Eric BĂ©langer
5 pkgver=3.6.0.r41.g31d1f125
6 _commit=31d1f125d8076f1c8c8f3224b31d240e6e6a1763
7 #_pkgver=${pkgver//./-}
10 pkgdesc="Collection of user space tools for general SMBus access and hardware monitoring"
12 url="https://hwmon.wiki.kernel.org/lm_sensors"
13 license=('GPL' 'LGPL')
14 optdepends=('rrdtool: for logging with sensord'
15 'perl: for sensor detection and configuration convert')
16 makedepends=('rrdtool' 'perl' 'git')
17 provides=('libsensors.so')
18 backup=('etc/sensors3.conf' 'etc/healthd.conf' 'etc/conf.d/sensord')
19 #source=(lm_sensors-${pkgver}.tar.gz::https://github.com/lm-sensors/lm-sensors/archive/V${_pkgver}.tar.gz
20 source=("git+https://github.com/groeck/lm-sensors.git#commit=${_commit}"
21 healthd healthd.conf healthd.service sensord.conf)
23 '0ac9afb2a9155dd74ab393756ed552cd542dde1081149beb2ab4ec7ff55b8f4a'
24 '5d17a366b175cf9cb4bb0115c030d4b8d91231546f713784a74935b6e533da9f'
25 '2638cd363e60f8d36bcac468f414a6ba29a1b5599f40fc651ca953858c8429d7'
26 '23bebef4c250f8c0aaba2c75fd3d2c8ee9473cc91a342161a9f5b3a34ddfa9e5')
27 validpgpkeys=('7CA69F4460F1BDC41FD2C858A5526B9BB3CD4E6A')
30 cd "${srcdir}"/lm-sensors*
32 git describe --long --tags | sed 's/V//;s/\([^-]*-g\)/r\1/;s/-/./g'
36 cd "${srcdir}"/lm-sensors*
37 sed -i 's|/etc/sysconfig|/etc/conf.d|' prog/{detect/sensors-detect,init/{sensord,lm_sensors}.service}
38 sed -i 's/EnvironmentFile=/EnvironmentFile=-/' prog/init/lm_sensors.service
42 cd "${srcdir}"/lm-sensors*
47 cd "${srcdir}"/lm-sensors*
48 make PROG_EXTRA=sensord BUILD_STATIC_LIB=0 \
49 PREFIX=/usr SBINDIR=/usr/bin MANDIR=/usr/share/man DESTDIR="${pkgdir}" install
51 install -D -m755 "${srcdir}/healthd" "${pkgdir}/usr/bin/healthd"
53 install -D -m644 "${srcdir}/healthd.conf" "${pkgdir}/etc/healthd.conf"
54 install -D -m644 "${srcdir}/sensord.conf" "${pkgdir}/etc/conf.d/sensord"
56 install -D -m644 "${srcdir}/healthd.service" "${pkgdir}/usr/lib/systemd/system/healthd.service"
57 install -D -m644 prog/init/*.service "${pkgdir}/usr/lib/systemd/system/"