1 # Maintainer: Rémy Oudompheng <remy@archlinux.org>
2 # Contributor: Mateusz Krasowski <matkras@gmail.com>
3 # Contributor: Luigi ranghetti <ggranga@gmail.com>
4 # Generator : CPANPLUS::Dist::Arch 1.25
6 pkgname='perl-autovivification'
7 _dist="autovivification"
10 pkgdesc="Lexically disable autovivification."
12 license=('PerlArtistic' 'GPL')
13 options=('!emptydirs')
14 depends=('perl>=5.8.3')
16 url='https://metacpan.org/release/autovivification'
17 source=("https://www.cpan.org/authors/id/V/VP/VPIT/autovivification-$pkgver.tar.gz")
18 sha256sums=('2d99975685242980d0a9904f639144c059d6ece15899efde4acb742d3253f105')
21 cd "${srcdir}/${_dist}-${pkgver}"
22 unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
23 export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
29 cd "${srcdir}/${_dist}-${pkgver}"
30 unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
31 export PERL_MM_USE_DEFAULT=1
36 cd "${srcdir}/${_dist}-${pkgver}"
37 unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
38 make install INSTALLDIRS=vendor DESTDIR="$pkgdir"