db-move: moved gcr from [testing] to [extra] (x86_64)
[arch-packages.git] / sgml-common / trunk / PKGBUILD
blob94cf3e0c3b989b72d058b877cd595aa4e203b381
1 # Maintainer: Felix Yan <felixonmars@gmail.com>
2 # Contributor: Andrew Fyfe <andrew@neptune-one.net>
3 # Maintainer: Jonas Heinrich <onny@project-insanity.org>
5 pkgname='sgml-common'
6 pkgver=0.6.3
7 pkgrel=8
8 pkgdesc='Tools for maintaining centralized SGML catalogs.'
9 arch=('any')
10 url='https://www.docbook.org/xml/'
11 license=('GPL')
12 install='sgml-common.install'
13 depends=('sh')
14 source=(#"ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-common-${pkgver}.tgz"
15         "https://www.sourceware.org/pub/docbook-tools/new-trials/SOURCES/sgml-common-${pkgver}.tgz"
16         'sgml-common-0.6.3-manpage-1.patch')
17 sha512sums=('3c4a55f555596b2a6bf6af66c497679226e7b40625ac16832150488311cba7f9fc523435eea5837262a5517f5c09c4c0e07fe4a2cf02184d4027609c26e4bc0c'
18             'c584ff6e66e1d58456c07849bf96fedd3f1df0b93430f6301c4d4ab9906821dea0cbac82eada19197540b5e31f13febd04fadda5b6e2ba4b0b6ee8f0328292f7')
20 prepare() {
21   cd sgml-common-${pkgver}
22   patch -Np1 -i ../sgml-common-0.6.3-manpage-1.patch
25 build() {
26   cd sgml-common-${pkgver}
27   autoreconf -vfi
28   ./configure --prefix=/usr --sysconfdir=/etc
29   make
31 package(){
32   cd sgml-common-${pkgver}
33   make DESTDIR="$pkgdir" docdir=/usr/share/doc install
35 #   "$pkgdir/usr/doc" "$pkgdir/usr/share/doc"