archrelease: copy trunk to extra-x86_64
[arch-packages.git] / celestia / repos / extra-x86_64 / PKGBUILD
blob993eb1052ebb1057b0b11dd815b708fb51fdd476
1 # Maintainer: Ronald van Haren <ronald.archlinux.org>
2 # Contributor : Damir Perisa <damir.perisa@bluewin.ch>
4 pkgname=celestia
5 pkgver=1.6.2.2
6 pkgrel=1
7 pkgdesc="Real-time space simulation"
8 arch=('x86_64')
9 license=('GPL')
10 url="https://celestia.space/"
11 depends=('gtk2' 'libtheora' 'lua53' 'gtkglext' 'glut' 'libxmu' 'glu' 'libjpeg' 'mesa')
12 options=('!makeflags')
13 source=("https://github.com/CelestiaProject/Celestia/archive/$pkgver/$pkgname-$pkgver.tar.gz"
14          celestia-fix-desktop.patch::"https://github.com/CelestiaProject/Celestia/commit/6a4a0573.patch")
15 sha1sums=('6e2fb4481dd69a5a81e31dc4352f2cf3680740d8'
16           '23d8963cceb407ff33171f87f8aa1ba5fa8839f9')
18 prepare() {
19     cd Celestia-${pkgver}
20     patch -p1 < ../celestia-fix-desktop.patch # Fix executable name in desktop file
21     autoreconf -vi
24 build() {
25     cd Celestia-${pkgver}
26     ./configure --prefix=/usr \
27                 --with-lua=/usr \
28                 --datadir=/usr/share \
29                 --with-gtk \
30                 --disable-rpath \
31                 --with-lua
32     make
35 package() {
36     cd Celestia-${pkgver}
38     make DESTDIR="${pkgdir}" MKDIR_P='mkdir -p' install