archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnote / trunk / PKGBUILD
blob6071cfd83ee7ad3dec68708c74f293cf0399a59d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 # Contributor: uastasi <uastasi@archlinux.us>
6 pkgname=gnote
7 pkgver=41.1
8 pkgrel=1
9 pkgdesc="A note taking application"
10 url="https://wiki.gnome.org/Apps/Gnote"
11 arch=(x86_64)
12 license=(GPL3)
13 depends=(gtkmm3 gspell libxslt dconf libsecret)
14 makedepends=(yelp-tools meson git)
15 _commit=236c6b0d109814e39daf8a6c404df21445afaf73  # tags/41.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnote.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build
37 package() {
38   meson install -C build --destdir "$pkgdir"