archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gucharmap / trunk / PKGBUILD
blob8d56793a74bc9bccc1fd0a341e235b0e6f979203
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan De Groot <jgc@archlinux.org>
4 pkgname=gucharmap
5 pkgver=14.0.1
6 pkgrel=1
7 pkgdesc="Gnome Unicode Charmap"
8 url="https://wiki.gnome.org/Apps/Gucharmap"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(dconf gtk3)
12 makedepends=(gtk-doc gobject-introspection yelp-tools appdata-tools git meson
13              unicode-character-database unzip vala)
14 provides=(libgucharmap_2_90.so)
15 _commit=3efb47b75b61d7c6db7e48d72f7aa8c4d4365011  # tags/14.0.1^0
16 source=("git+https://gitlab.gnome.org/GNOME/gucharmap.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build -D ucd_path=/usr/share/unicode
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"