archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libchamplain / trunk / PKGBUILD
blob98fd9f7e9622147bbe1e71ccfe0d361912584668
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Andreas Radke <andyrtr@archlinux.org>
3 # Contributor: Michael Kanis <mkanis@gmx.de>
5 pkgname=libchamplain
6 pkgver=0.12.20
7 pkgrel=2
8 pkgdesc="A map widget"
9 url="https://wiki.gnome.org/Projects/libchamplain"
10 license=(LGPL)
11 arch=(x86_64)
12 depends=(clutter-gtk libsoup cairo sqlite)
13 makedepends=(gobject-introspection gtk-doc vala meson git)
14 _commit=145e417f32e507b63c21ad4e915b808a6174099e  # tags/LIBCHAMPLAIN_0_12_20^0
15 source=("git+https://gitlab.gnome.org/GNOME/libchamplain.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/^LIBCHAMPLAIN_//;s/_/./g;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -D gtk_doc=true
29   ninja -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build