archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libgepub / trunk / PKGBUILD
blobcc9bcad868d11220c7bb21e774e2cec4f1983a08
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
3 pkgname=libgepub
4 pkgver=0.6.0
5 pkgrel=2
6 pkgdesc="Simple library to read epub files using glib"
7 url="https://gitlab.gnome.org/GNOME/libgepub"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(webkit2gtk libarchive)
11 makedepends=(git gtk-doc gobject-introspection meson)
12 _commit=ecca0e1e8f2c301b1ea769e618a92125ee934b57  # tags/0.6.0^0
13 source=("git+https://gitlab.gnome.org/GNOME/libgepub.git#commit=$_commit")
14 sha256sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
25 build() {
26   arch-meson $pkgname build
27   ninja -C build
30 check() {
31   meson test -C build --print-errorlogs
34 package() {
35   DESTDIR="$pkgdir" meson install -C build