archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libxml++ / trunk / PKGBUILD
blob971e4e162c9352772a1273a704e1c9da8c86f216
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: damir <damir@archlinux.org>
4 pkgbase=libxml++
5 pkgname=(libxml++ libxml++-docs)
6 pkgver=3.2.3
7 pkgrel=1
8 pkgdesc="C++ bindings to libxml2"
9 url="https://libxmlplusplus.github.io/libxmlplusplus/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(libxml2 glibmm)
13 makedepends=(git meson mm-common glibmm-docs)
14 options=(!emptydirs)
15 _commit=e844282958af940cf374302c22b369dbdaa1fcdd  # tags/3.2.3^0
16 source=("git+https://github.com/libxmlplusplus/libxmlplusplus#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd libxmlplusplus
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd libxmlplusplus
28 build() {
29   arch-meson libxmlplusplus build -D maintainer-mode=true
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 # Do not remove the space before the () or commitpkg will
38 # accidentally to run this function on the system (!!!) 
39 package_libxml++ () {
40   provides=(libxml++-3.0.so)
42   meson install -C build --destdir "$pkgdir"
44   # Split -docs
45   mkdir -p docs/usr/share
46   mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
49 package_libxml++-docs() {
50   pkgdesc+=" (documentation)"
51   depends=()
52   options=(!strip)
54   mv -t "$pkgdir" docs/*