1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: damir <damir@archlinux.org>
5 pkgname=(libxml++ libxml++-docs)
8 pkgdesc="C++ bindings to libxml2"
9 url="https://libxmlplusplus.github.io/libxmlplusplus/"
12 depends=(libxml2 glibmm)
13 makedepends=(git meson mm-common glibmm-docs)
15 _commit=e844282958af940cf374302c22b369dbdaa1fcdd # tags/3.2.3^0
16 source=("git+https://github.com/libxmlplusplus/libxmlplusplus#commit=$_commit")
21 git describe --tags | sed 's/-/+/g'
29 arch-meson libxmlplusplus build -D maintainer-mode=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
37 # Do not remove the space before the () or commitpkg will
38 # accidentally to run this function on the system (!!!)
40 provides=(libxml++-3.0.so)
42 meson install -C build --destdir "$pkgdir"
45 mkdir -p docs/usr/share
46 mv -t docs/usr/share "$pkgdir"/usr/share/{devhelp,doc}
49 package_libxml++-docs() {
50 pkgdesc+=" (documentation)"
54 mv -t "$pkgdir" docs/*