archrelease: copy trunk to extra-x86_64
[arch-packages.git] / mutter / trunk / PKGBUILD
blob592772351f1e858720e47a7b66632b0e279a59c9
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
5 pkgname=mutter
6 pkgver=41.2
7 pkgrel=1
8 pkgdesc="A window manager for GNOME"
9 url="https://gitlab.gnome.org/GNOME/mutter"
10 arch=(x86_64)
11 license=(GPL)
12 depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas
13          libcanberra startup-notification zenity libsm gnome-desktop upower
14          libxkbcommon-x11 gnome-settings-daemon libgudev libinput pipewire
15          xorg-xwayland graphene libxkbfile)
16 makedepends=(gobject-introspection git egl-wayland meson xorg-server
17              wayland-protocols)
18 checkdepends=(xorg-server-xvfb pipewire-media-session python-dbusmock)
19 provides=(libmutter-9.so)
20 groups=(gnome)
21 _commit=664ac09eecfd365b5258f53d2c9e6c8410a37919  # tags/41.2^0
22 source=("git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit")
23 sha256sums=('SKIP')
25 pkgver() {
26   cd $pkgname
27   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
30 prepare() {
31   cd $pkgname
34 build() {
35   CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
36   LDFLAGS+=" -Wl,-Bsymbolic-functions"
37   arch-meson $pkgname build \
38     -D egl_device=true \
39     -D wayland_eglstream=true \
40     -D installed_tests=false \
41     -D profiler=false
42   meson compile -C build
45 _check() (
46   mkdir -p -m 700 "${XDG_RUNTIME_DIR:=$PWD/runtime-dir}"
47   glib-compile-schemas "${GSETTINGS_SCHEMA_DIR:=$PWD/build/data}"
48   export XDG_RUNTIME_DIR GSETTINGS_SCHEMA_DIR
50   pipewire &
51   _p1=$!
53   pipewire-media-session &
54   _p2=$!
56   trap "kill $_p1 $_p2; wait" EXIT
58   meson test -C build --print-errorlogs
61 check() {
62   dbus-run-session xvfb-run -s '-nolisten local' \
63     bash -c "$(declare -f _check); _check"
66 package() {
67   meson install -C build --destdir "$pkgdir"