archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pkcs11-helper / repos / extra-x86_64 / PKGBUILD
bloba042058ca0023385525cc31ee9ec14bf03589d3a
1 # Maintainer:
2 # Contributor: Stanislaw Datskevich <me a nek0 net>
3 # Contributor: Gregor Robinson <gregor@fiatflux.co.uk>
4 # Contributor: Martin Perner <martin dot perner at gmail dot com>
6 pkgname=pkcs11-helper
7 pkgver=1.27.0
8 pkgrel=2
9 pkgdesc="A library that simplifies the interaction with PKCS11 providers for end-user applications using a simple API and optional OpenSSL engine"
10 arch=('x86_64')
11 url='https://github.com/OpenSC/pkcs11-helper'
12 license=(GPL BSD)
13 depends=('gnutls' 'nss' 'openssl')
14 provides=('libpkcs11-helper.so')
15 source=("https://github.com/OpenSC/${pkgname}/releases/download/${pkgname}-${pkgver%.0}/${pkgname}-${pkgver}.tar.bz2"
16         '0001-nss-use-nss-pkcs11-h.patch')
17 sha256sums=('653730f0c561bbf5941754c0783976113589b2dc64a0661c908dc878bfa4e58b'
18             'a4a27c9f71c5f2cf57a79eeba2c6749424393c20e6b5967f46095b10f393f439')
20 prepare() {
21   cd pkcs11-helper-$pkgver
23   patch -Np1 < ../0001-nss-use-nss-pkcs11-h.patch
26 build() {
27   cd pkcs11-helper-$pkgver
29   libtoolize
30   aclocal
31   autoheader
32   automake --add-missing
33   autoreconf -v
34   ./configure --prefix=/usr
35   make
38 package() {
39   cd pkcs11-helper-$pkgver
41   make DESTDIR="$pkgdir" install
42   mkdir -p "$pkgdir"/usr/share/licenses/$pkgname/
43   install -D -m0644 COPYING* "$pkgdir"/usr/share/licenses/$pkgname/