archrelease: copy trunk to extra-x86_64
[arch-packages.git] / plasma-browser-integration / trunk / PKGBUILD
blob694513bfb8eb62e30b71586f293422811f984713
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-browser-integration
4 pkgver=5.23.4
5 pkgrel=1
6 pkgdesc='Components necessary to integrate browsers into the Plasma Desktop'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(GPL)
10 depends=(purpose kfilemetadata plasma-workspace)
11 makedepends=(extra-cmake-modules)
12 groups=(plasma)
13 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
14 sha256sums=('09a418c5937357ae437b8d2baec9f183126ff5d13c94a05ed80f4480b4018400'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
21 build() { 
22   cmake -B build -S $pkgname-$pkgver \
23     -DINSTALL_CHROME_MANIFEST=ON
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build