1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
6 pkgdesc="A super-fast templating language that borrows the best ideas from the existing templating languages"
8 url="https://www.makotemplates.org/"
10 depends=('python-markupsafe' 'python-beaker' 'python-setuptools')
11 checkdepends=('python-pytest' 'python-mock' 'python-babel' 'python-pygments'
12 'python-dogpile.cache')
13 source=("https://pypi.io/packages/source/M/Mako/Mako-$pkgver.tar.gz"{,.asc})
14 sha512sums=('e87d883d7a549a902bb2e16d20306ccd3dd7b3bf855dfdaff20477dd182a782a5cecbdc447e4b1607f190a7b0febcca001333137f7cac6ffa674824c2a2fd1bb'
16 validpgpkeys=('83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1') # Michael Bayer
20 sed -e '/\[tool:pytest\]/a filterwarnings =\n error\n ignore:Creating a LegacyVersion has been deprecated and will be removed in the next major release:DeprecationWarning' \
37 python setup.py install --root="$pkgdir" --optimize=1
38 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE