archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python-mako / trunk / PKGBUILD
blobbef810020bf441125d4aad67af9b42f4bd87d8d4
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-mako
4 pkgver=1.1.6
5 pkgrel=3
6 pkgdesc="A super-fast templating language that borrows the best ideas from the existing templating languages"
7 arch=('any')
8 url="https://www.makotemplates.org/"
9 license=('MIT')
10 depends=('python-markupsafe' 'python-beaker' 'python-setuptools')
11 checkdepends=('python-pytest' 'python-mock' 'python-babel' 'python-pygments'
12               'python-dogpile.cache')
13 source=("https://pypi.io/packages/source/M/Mako/Mako-$pkgver.tar.gz"{,.asc})
14 sha512sums=('e87d883d7a549a902bb2e16d20306ccd3dd7b3bf855dfdaff20477dd182a782a5cecbdc447e4b1607f190a7b0febcca001333137f7cac6ffa674824c2a2fd1bb'
15             'SKIP')
16 validpgpkeys=('83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1')  # Michael Bayer
18 prepare() {
19   cd Mako-$pkgver
20   sed -e '/\[tool:pytest\]/a filterwarnings =\n    error\n    ignore:Creating a LegacyVersion has been deprecated and will be removed in the next major release:DeprecationWarning' \
21       -e 's/-W error//' \
22       -i setup.cfg
25 build() {
26   cd Mako-$pkgver
27   python setup.py build
30 check() {
31   cd Mako-$pkgver
32   python -m pytest
35 package() {
36   cd Mako-$pkgver
37   python setup.py install --root="$pkgdir" --optimize=1
38   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE