archrelease: copy trunk to extra-x86_64
[arch-packages.git] / python / trunk / PKGBUILD
blobfeb4e4f916e4ce995db79a643d662afea837f1f6
1 # Maintainer: Angel Velasquez <angvp@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
4 # Contributor: Allan McRae <allan@archlinux.org>
5 # Contributor: Jason Chu <jason@archlinux.org>
7 shopt -s extglob
9 pkgbase=python
10 pkgname=(python python-tests)
11 pkgver=3.10.1
12 pkgrel=1
13 _pybasever=${pkgver%.*}
14 pkgdesc="Next generation of the python high-level scripting language"
15 arch=('x86_64')
16 license=('custom')
17 url="https://www.python.org/"
18 depends=('bzip2' 'expat' 'gdbm' 'libffi' 'libnsl' 'libxcrypt' 'openssl' 'zlib')
19 makedepends=('tk' 'sqlite' 'bluez-libs' 'mpdecimal' 'llvm' 'gdb' 'xorg-server-xvfb' 'ttf-font')
20 source=("https://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"{,.asc}
21         https://bugs.python.org/file50485/cmp_interned_strings.patch)
22 sha512sums=('1c559e33f1252e51bafb941c380de16f142c0735858363c84cb8dbed6767843de3af126889c2826ffb94bd4777d7cdfc31040301c8c74de56af52b80b1aa9e76'
23             'SKIP'
24             'd97fe57566169bfc06713d4aa420e1c85c0b9c1d0f96d61cdd3a4a86b2340753a80c56e0d48c16b513e3f639cee83b7fbbc0c21045d2f37bf37543048f914557')
25 validpgpkeys=('0D96DF4D4110E5C43FBFB17F2D347EA6AA65421D'  # Ned Deily (Python release signing key) <nad@python.org>
26               'E3FF2839C048B25C084DEBE9B26995E310250568'  # Łukasz Langa (GPG langa.pl) <lukasz@langa.pl>
27               'A035C8C19219BA821ECEA86B64E628F8D684696D') # Pablo Galindo Salgado <pablogsal@gmail.com>
29 prepare() {
30   cd Python-${pkgver}
32   # FS#72979
33   patch -Np1 -i ../cmp_interned_strings.patch
35   # FS#23997
36   sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python|" Lib/cgi.py
38   # Speed up LTO
39   sed -i -e "s|-flto |-flto=4 |g" configure configure.ac
41   # Ensure that we are using the system copy of various libraries (expat, libffi, and libmpdec),
42   # rather than copies shipped in the tarball
43   rm -r Modules/expat
44   rm -r Modules/_ctypes/{darwin,libffi}*
45   rm -r Modules/_decimal/libmpdec
48 build() {
49   cd Python-${pkgver}
51   # PGO should be done with -O3
52   CFLAGS="${CFLAGS/-O2/-O3}"
54   # Disable bundled pip & setuptools
55   ./configure --prefix=/usr \
56               --enable-shared \
57               --with-computed-gotos \
58               --enable-optimizations \
59               --with-lto \
60               --enable-ipv6 \
61               --with-system-expat \
62               --with-dbmliborder=gdbm:ndbm \
63               --with-system-ffi \
64               --with-system-libmpdec \
65               --enable-loadable-sqlite-extensions \
66               --without-ensurepip \
67               --with-tzpath=/usr/share/zoneinfo
69   # Obtain next free server number for xvfb-run; this even works in a chroot environment.
70   export servernum=99
71   while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
73   LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" make EXTRA_CFLAGS="$CFLAGS"
76 check() {
77   # test_socket: test.test_socket.RDSTest.testPeek hangs https://bugs.python.org/issue35247
78   # test_tk: tkinter.test.test_tkinter.test_colorchooser.DefaultRootTest hangs
79   # test_ttk_guionly: test failures about "AssertionError: TclError not raised"
81   cd Python-${pkgver}
83   # Obtain next free server number for xvfb-run; this even works in a chroot environment.
84   export servernum=99
85   while ! xvfb-run -a -n "$servernum" /bin/true 2>/dev/null; do servernum=$((servernum+1)); done
87   LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
88   LC_CTYPE=en_US.UTF-8 xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum" \
89     "${srcdir}/Python-${pkgver}/python" -m test.regrtest -v -uall -x test_socket -x test_tk -x test_ttk_guionly
92 package_python() {
93   optdepends=('python-setuptools'
94               'python-pip'
95               'sqlite'
96               'mpdecimal: for decimal'
97               'xz: for lzma'
98               'tk: for tkinter')
99   provides=('python3')
100   replaces=('python3')
102   cd Python-${pkgver}
104   # Hack to avoid building again
105   sed -i 's/^all:.*$/all: build_all/' Makefile
107   # PGO should be done with -O3
108   CFLAGS="${CFLAGS/-O2/-O3}"
110   make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" install
112   # Split tests
113   rm -r "$pkgdir"/usr/lib/python*/{test,ctypes/test,distutils/tests,idlelib/idle_test,lib2to3/tests,sqlite3/test,tkinter/test,unittest/test}
115   # Why are these not done by default...
116   ln -s python3               "${pkgdir}"/usr/bin/python
117   ln -s python3-config        "${pkgdir}"/usr/bin/python-config
118   ln -s idle3                 "${pkgdir}"/usr/bin/idle
119   ln -s pydoc3                "${pkgdir}"/usr/bin/pydoc
120   ln -s python${_pybasever}.1 "${pkgdir}"/usr/share/man/man1/python.1
122   # some useful "stuff" FS#46146
123   install -dm755 "${pkgdir}"/usr/lib/python${_pybasever}/Tools/{i18n,scripts}
124   install -m755 Tools/i18n/{msgfmt,pygettext}.py "${pkgdir}"/usr/lib/python${_pybasever}/Tools/i18n/
125   install -m755 Tools/scripts/{README,*py} "${pkgdir}"/usr/lib/python${_pybasever}/Tools/scripts/
127   # License
128   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
131 package_python-tests() {
132   pkgdesc="Regression tests packages for Python"
133   depends=('python')
135   cd Python-${pkgver}
137   make DESTDIR="${pkgdir}" EXTRA_CFLAGS="$CFLAGS" libinstall
138   cd "$pkgdir"/usr/lib/python*/
139   rm -r !(test|ctypes|distutils|idlelib|lib2to3|sqlite3|tkinter|unittest)
140   cd "$pkgdir"/usr/lib/python*/ctypes
141   rm -r !(test)
142   cd "$pkgdir"/usr/lib/python*/distutils
143   rm -r !(tests)
144   cd "$pkgdir"/usr/lib/python*/idlelib
145   rm -r !(idle_test)
146   cd "$pkgdir"/usr/lib/python*/lib2to3
147   rm -r !(tests)
148   cd "$pkgdir"/usr/lib/python*/sqlite3
149   rm -r !(test)
150   cd "$pkgdir"/usr/lib/python*/tkinter
151   rm -r !(test)
152   cd "$pkgdir"/usr/lib/python*/unittest
153   rm -r !(test)