archrelease: copy trunk to extra-x86_64
[arch-packages.git] / template-glib / trunk / PKGBUILD
blob9eae161c532d7d47545a8407f63b47b62268781e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=template-glib
4 pkgver=3.34.0+4+g5196521
5 pkgrel=1
6 pkgdesc="A templating library for GLib"
7 url="https://gitlab.gnome.org/GNOME/template-glib"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(glib2 gobject-introspection-runtime)
11 makedepends=(git meson vala gobject-introspection gtk-doc)
12 provides=(libtemplate_glib-1.0.so)
13 _commit=51965216367391583fd87d1a20cd9ba2bc4943d2  # master
14 source=("git+https://gitlab.gnome.org/GNOME/template-glib.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -D enable_gtk_doc=true
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   DESTDIR="$pkgdir" meson install -C build