archrelease: copy trunk to extra-x86_64
[arch-packages.git] / varnish / trunk / PKGBUILD
blob136ef6b0b08d94145727db7cd3a1fc84c345e550
1 # Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
2 # Contributor: Dave Reisner <dreisner@archlinux.org>
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Douglas Soares de Andrade
5 # Contributor: Roberto Alsina <ralsina@kde.org>
7 pkgname=varnish
8 pkgver=7.0.1
9 pkgrel=1
10 pkgdesc="High-performance HTTP accelerator"
11 arch=('x86_64')
12 url="https://www.varnish-cache.org/"
13 license=('BSD')
14 depends=('gcc' 'libnsl' 'pcre2')
15 makedepends=('python-docutils' 'python-sphinx' 'git')
16 optdepends=('python: needed for vmod development')
17 backup=('etc/varnish/default.vcl')
18 install=$pkgname.install
19 source=("https://varnish-cache.org/_downloads/varnish-$pkgver.tgz"
20         "git+https://github.com/varnishcache/pkg-varnish-cache.git#commit=d3e6a3f"
21         varnish.sysusers)
22 sha512sums=('7541d50b03a113f0a13660d459cc4c2eb45d57fb19380ab56a5413a4e5d702f9c0856585f09aeea6084a239ad8c69017af3805a864540b4697e0eac29f00b408'
23             'SKIP'
24             '1eeeba4ab990c1790495f9ff4625ad37f21e155e08e0c255e09d18c44054f3a59613b81c07d8701610b0b266e5181ae8bbae2523138737f3c4f0e1a6c287bb0c')
26 prepare() {
27   cd "varnish-$pkgver"
29   ./autogen.sh
32 build() {
33   cd "varnish-$pkgver"
35   ./configure \
36     --prefix=/usr \
37     --sysconfdir=/etc \
38     --localstatedir=/var/lib \
39     --sbindir=/usr/bin
41   make
44 # check() {
45 #   cd "varnish-$pkgver"
47 #   make check
48 # }
50 package() {
51   cd "varnish-$pkgver"
53   make DESTDIR="$pkgdir" install
55   install -Dm644 "$srcdir/pkg-varnish-cache/systemd/varnish.service" "$pkgdir/usr/lib/systemd/system/varnish.service"
56   install -Dm644 "$srcdir/pkg-varnish-cache/systemd/varnishncsa.service" "$pkgdir/usr/lib/systemd/system/varnishncsa.service"
57   install -Dm755 "$srcdir/pkg-varnish-cache/systemd/varnishreload" "$pkgdir/usr/bin/varnishreload"
58   install -Dm755 "$srcdir/pkg-varnish-cache/systemd/varnish.logrotate" "$pkgdir/etc/logrotate.d/varnish"
60   # create varnish:varnish user/group
61   install -Dm644 "$srcdir/varnish.sysusers" "$pkgdir/usr/lib/sysusers.d/varnish.conf"
63   # config
64   install -Dm644 "etc/example.vcl" "$pkgdir/etc/varnish/default.vcl"
65   install -Dm644 "etc/builtin.vcl" "$pkgdir/usr/share/doc/varnish/builtin.vcl"
67   # license
68   install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"