archrelease: copy trunk to extra-x86_64
[arch-packages.git] / vi / trunk / PKGBUILD
blob6ce7628e1fdb4fab5886a48143b58482c8617093
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
4 pkgname=vi
5 pkgver=070224
6 pkgrel=5
7 epoch=1
8 pkgdesc="The original ex/vi text editor"
9 arch=('x86_64')
10 url="http://ex-vi.sourceforge.net/"
11 license=('custom:ex')
12 depends=('ncurses')
13 optdepends=('s-nail: used by the preserve command for notification')
14 source=(https://sources.archlinux.org/other/$pkgname/ex-$pkgver.tar.xz{,.sig}
15         fix-tubesize-short-overflow.patch
16         navkeys.patch
17         linenum.patch
18         preserve-dir.patch)
19 sha256sums=('c3e52dd44edd1f6bf0b52207f717c56149dc50aac0d131fff3851d589727f52f'
20             'SKIP'
21             '42167fabebe30a13d594346b1d254db82090ba41742a9f35b8895d37092053f0'
22             '0e9e2d381f1d8cb86daae68462b3849825b003c08007725c0db9939d3d5bf58d'
23             '4539f46cd839475c168a9c463f041354463e90e810b973a10c499c2727b008e7'
24             'f0ef9ed2ccea98bf47b08dd3faa2abb911b4e6c0579f5294e9d0e8742282ff65')
25 validpgpkeys=('86CFFCA918CF3AF47147588051E8B148A9999C34')
27 prepare() {
28   cd ex-$pkgver
30   patch -Np1 -i ../fix-tubesize-short-overflow.patch
31   patch -Np1 -i ../navkeys.patch
33   # https://bugs.archlinux.org/task/70770
34   patch -Np1 -i ../linenum.patch
36   # https://bugs.archlinux.org/task/20653
37   patch -Np1 -i ../preserve-dir.patch
40 build() {
41   cd ex-$pkgver
43   make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex \
44     TERMLIB=ncurses FEATURES="-DCHDIR -DFASTTAG -DUCVISUAL -DMB -DBIT8"
47 package() {
48   cd ex-$pkgver
50   make PREFIX=/usr LIBEXECDIR=/usr/lib/ex PRESERVEDIR=/var/lib/ex \
51     INSTALL=/usr/bin/install DESTDIR="$pkgdir" install
52   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
55 # vim:set ts=2 sw=2 et: