archrelease: copy trunk to extra-x86_64
[arch-packages.git] / wget / trunk / PKGBUILD
blobcb2513dca3a49cb8655804c9be6307bd7689c67f
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Maintainer: Eric Bélanger <eric@archlinux.org>
4 pkgname=wget
5 pkgver=1.21.2
6 pkgrel=1
7 pkgdesc='Network utility to retrieve files from the Web'
8 url='https://www.gnu.org/software/wget/wget.html'
9 arch=('x86_64')
10 license=('GPL3')
11 depends=('glibc' 'zlib' 'gnutls' 'libidn2' 'libidn2.so' 'util-linux-libs' 'libuuid.so'
12          'libpsl' 'libpsl.so' 'pcre2' 'nettle' 'libnettle.so')
13 checkdepends=('perl-http-daemon' 'perl-io-socket-ssl' 'python')
14 optdepends=('ca-certificates: HTTPS downloads')
15 backup=('etc/wgetrc')
16 source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.lz{,.sig})
17 sha256sums=('1727a330a86acacb3e57615ce268f5f29978bf7adec4abe6a30d370207bc91b3'
18             'SKIP')
19 b2sums=('9141b27f2db587bbd34cb97ecf4a6179e564817067b45c8168390cf1548c1a18f71723247d82b11f2edf3981a9b9f0d2097afe5d56397e033b0a86adae9482b1'
20         'SKIP')
21 validpgpkeys=(
22   'AC404C1C0BF735C63FF4D562263D6DF2E163E1EA' # Giuseppe Scrivano <gscrivano@gnu.org>
23   '7845120B07CBD8D6ECE5FF2B2A1743EDA91A35B6' # Darshit Shah <darnir@gnu.org>
24   '1CB27DBC98614B2D5841646D08302DB6A2670428' # Tim Rühsen <tim.ruehsen@gmx.de>
27 prepare() {
28   cd ${pkgname}-${pkgver}
29   cat >> doc/sample.wgetrc <<EOF
31 # default root certs location
32 ca_certificate=/etc/ssl/certs/ca-certificates.crt
33 EOF
36 build() {
37   cd ${pkgname}-${pkgver}
38   ./configure \
39     --prefix=/usr \
40     --sysconfdir=/etc \
41     --disable-rpath \
42     --enable-nls \
43     --with-ssl=gnutls
44   make
47 check() {
48   cd ${pkgname}-${pkgver}
49   make check < /dev/null
52 package() {
53   cd ${pkgname}-${pkgver}
54   make DESTDIR="${pkgdir}" install
57 # vim: ts=2 sw=2 et: