archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-contacts / trunk / PKGBUILD
blobbbe05de29e64e3dec22e5117937ba19614de1c72
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-contacts
5 pkgver=44.0
6 pkgrel=1
7 pkgdesc="Contacts Manager for GNOME"
8 url="https://wiki.gnome.org/Apps/Contacts"
9 arch=(x86_64)
10 license=(GPL2)
11 depends=(
12   evolution-data-server
13   folks
14   gnome-online-accounts
15   gtk4
16   libadwaita
17   libgee
18   libportal-gtk4
19   qrencode
21 makedepends=(
22   appstream-glib
23   git
24   gobject-introspection
25   meson
26   vala
28 groups=(gnome)
29 _commit=7de4264212aac05f8acec29ba54adac90ae8ed39  # tags/44.0^0
30 source=("git+https://gitlab.gnome.org/GNOME/gnome-contacts.git#commit=$_commit")
31 b2sums=('SKIP')
33 pkgver() {
34   cd $pkgname
35   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
38 prepare() {
39   cd $pkgname
42 build() {
43   arch-meson $pkgname build
44   meson compile -C build
47 check() {
48   meson test -C build --print-errorlogs
51 package() {
52   meson install -C build --destdir "$pkgdir"
55 # vim:set sw=2 sts=-1 et: