archrelease: copy trunk to extra-x86_64
[arch-packages.git] / kweathercore / repos / extra-x86_64 / PKGBUILD
blob40f983904f5e2c75c89834a489f271e553a81efe
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=kweathercore
4 pkgver=0.7
5 pkgrel=1
6 pkgdesc='Library to facilitate retrieval of weather information including forecasts and alerts'
7 arch=(x86_64)
8 license=(GPL)
9 url='https://invent.kde.org/libraries/kweathercore'
10 depends=(ki18n kholidays qt5-location)
11 makedepends=(extra-cmake-modules doxygen qt5-tools)
12 source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
13 sha256sums=('04dde83ae543163735776dc50edab3510247d4825432840a78fade9b237a79fd'
14             'SKIP')
15 validpgpkeys=(0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D) # Bhushan Shah (mykolab address) <bshah@mykolab.com>
17 build() {
18   cmake -B build -S $pkgname-$pkgver \
19     -DBUILD_TESTING=OFF \
20     -DBUILD_QCH=ON
21   cmake --build build
24 package() {
25   DESTDIR="$pkgdir" cmake --install build