archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libxshmfence / repos / extra-x86_64 / PKGBUILD
blobd839bd5196e16a4d76ea53ae6da74ad904fa3ea2
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=libxshmfence
4 pkgver=1.3.2
5 pkgrel=1
6 pkgdesc="a library that exposes a event API on top of Linux futexes"
7 arch=('x86_64')
8 url="https://xorg.freedesktop.org/"
9 license=('GPL')
10 #groups=()
11 depends=('glibc')
12 makedepends=('xorg-util-macros' 'xorgproto')
13 options=('debug')
14 source=(${url}/archive/individual/lib/${pkgname}-${pkgver}.tar.xz{,.sig})
15 sha512sums=('e20a6827e370726cf50489a69f4a52b897f1c44e3eba8c72a4e626b08724e877d090770b8016765736d887d5d5eaba1fda9c29066e62d259b4d1e2064bc1626c'
16             'SKIP')
17 #validpgpkeys=('C383B778255613DFDB409D91DB221A6900000011') # Keith Packard <keithp@keithp.com>
18 validpgpkeys=('3BB639E56F861FA2E86505690FDD682D974CA72A') # "Matt Turner <mattst88@gmail.com>"
19 #validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # Alan Coopersmith <alan.coopersmith@oracle.com>
21 build() {
22   cd $pkgname-$pkgver
23   ./configure --prefix=/usr
24   make
27 check() {
28   cd $pkgname-$pkgver
29   make -k check
32 package() {
33   cd $pkgname-$pkgver
34   make DESTDIR="$pkgdir/" install
35   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
36   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"