archrelease: copy trunk to extra-x86_64
[arch-packages.git] / man-db / trunk / PKGBUILD
blob15f68e6a4a7cd4651ce8f5f96e03cae214902b16
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Sergej Pupykin <sergej@aur.archlinux.org>
4 pkgname=man-db
5 pkgver=2.11.2
6 pkgrel=1
7 pkgdesc="A utility for reading man pages"
8 arch=('x86_64')
9 url="https://gitlab.com/cjwatson/man-db"
10 license=('GPL' 'LGPL')
11 depends=( 'bash' 'gdbm' 'zlib' 'groff' 'libpipeline' 'less' 'libseccomp')
12 makedepends=('po4a')
13 optdepends=('gzip') # covered by virtual "base" package
14 backup=('etc/man_db.conf')
15 conflicts=('man')
16 provides=('man')
17 replaces=('man')
18 install=${pkgname}.install
19 source=(https://savannah.nongnu.org/download/man-db/$pkgname-$pkgver.tar.xz{,.asc}
20         # fallback should be used within first 24h after a release
21         #https://download-mirror.savannah.gnu.org/releases/man-db/$pkgname-$pkgver.tar.xz{,.asc} 
22         convert-mans
24 validpgpkeys=('AC0A4FF12611B6FCCF01C111393587D97D86500B') # Colin Watson <cjwatson@debian.org>
25 sha512sums=('edb71cce7249c7b7f2f524e92f682047a77ed9ae8856763dfc8e18e239444651ff4c505e697f5a8b1be3b85678e714fbb1a520defe72a4eb685bc2cecc0e4391'
26             'SKIP'
27             '0b159285da20008f0fc0afb21f1eaebd39e8df5b0594880aa0e8a913b656608b8d16bb8d279d9e62d7aae52f62cb9b2fc49e237c6711f4a5170972b38d345535')
29 build() {
30   cd ${pkgname}-${pkgver}
31   ./configure --prefix=/usr \
32     --sbindir=/usr/bin \
33     --sysconfdir=/etc \
34     --libexecdir=/usr/lib \
35     --with-systemdsystemunitdir=/usr/lib/systemd/system \
36     --with-snapdir=/var/lib/snapd/snap \
37     --with-db=gdbm \
38     --disable-setuid \
39     --enable-cache-owner=root \
40     --enable-mandirs=GNU \
41     --with-sections="1 1p n l 8 3 3p 0 0p 2 3type 5 4 9 6 7"
42   make
45 check() {
46   cd ${pkgname}-${pkgver}
47   make check
50 package() {
51   cd ${pkgname}-${pkgver}
52   make DESTDIR=${pkgdir} install
54   # part of groff pkg
55   rm -f ${pkgdir}/usr/bin/zsoelim
57   # script from LFS to convert manpages, see
58   # http://www.linuxfromscratch.org/lfs/view/6.4/chapter06/man-db.html
59   install -D -m755 ${srcdir}/convert-mans  ${pkgdir}/usr/bin/convert-mans
61   install -d -m755 ${pkgdir}/usr/lib/systemd/system/timers.target.wants
62   ln -s ../man-db.timer ${pkgdir}/usr/lib/systemd/system/timers.target.wants/man-db.timer