archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ncurses / repos / core-x86_64 / PKGBUILD
blobdcbb5fb4f89b046c65c27f81e22ca5db799668ac
1 # Maintainer:  David Runge <dvzrv@archlinux.org>
2 # Contributor:  BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: judd <jvinet@zeroflux.org>
6 pkgname=ncurses
7 pkgver=6.4
8 pkgrel=1
9 pkgdesc='System V Release 4.0 curses emulation library'
10 arch=(x86_64)
11 url='https://invisible-island.net/ncurses/ncurses.html'
12 license=(MIT)
13 depends=(glibc gcc-libs)
14 makedepends=(autoconf-archive)
15 optdepends=('bash: for ncursesw6-config')
16 provides=(libncurses++w.so libformw.so libmenuw.so libpanelw.so libncursesw.so)
17 replaces=(alacritty-terminfo)
18 options=(debug)
19 source=(
20   https://invisible-mirror.net/archives/$pkgname/$pkgname-$pkgver.tar.gz{,.asc}
21   $pkgname-6.3-libs.patch
22   $pkgname-6.3-pkgconfig.patch
24 sha512sums=('1c2efff87a82a57e57b0c60023c87bae93f6718114c8f9dc010d4c21119a2f7576d0225dab5f0a227c2cfc6fb6bdbd62728e407f35fce5bf351bb50cf9e0fd34'
25             'SKIP'
26             'adb02b838c40f1e58a1b31c26d5cd0f2a1c43f3b6d68e839981764c0f6c905a9eb51dd36ff018628fdeb20747cc7467727d57135408ab4848259384077a52b28'
27             '2d2c0ec3c880e638ab4aa3dbff5e28e4cd233153e24816bd87e077f848aa3edd5114cd0f2a7f6e8869dd1861a2746e512886c18264ff1676927dcc320c5ef958')
28 b2sums=('47fd9c2d27f44fa9942552881a471e5067465dbace40bf68b28998dded0556127a1d8662b96de4de4fd76c1c8b98bdae796036553ab4b05ca9f160839d841ba3'
29         'SKIP'
30         '31bb10e82dd018a75e57252052650d9f0f5eb5e7e887118c2ea40032b11f59ec6aa4d9bae804c615cbecdf3382f3434e0c9e9e8440fdefe66a507be020b8965c'
31         'fb6cf606cf3db7f6b306272696a63bce83d52cfa91e850f9a7bdb9d3d8455a26943529a9cf79731dddc7f763c27211a9afab9c4c31dbb6d12fd720eb390eb0a3')
32 validpgpkeys=('19882D92DDA4C400C22C0D56CC2AF4472167BE03')  # Thomas Dickey <dickey@invisible-island.net>
34 prepare() {
35   # do not link against test libraries
36   patch -Np1 -d $pkgname-$pkgver -i ../$pkgname-6.3-libs.patch
37   # do not leak build-time LDFLAGS into the pkgconfig files:
38   # https://bugs.archlinux.org/task/68523
39   patch -Np1 -d $pkgname-$pkgver -i ../$pkgname-6.3-pkgconfig.patch
40   # NOTE: can't run autoreconf because the autotools setup is custom and ancient
43 build() {
44   local configure_options=(
45     --prefix=/usr
46     --enable-widec
47     --enable-pc-files
48     --mandir=/usr/share/man
49     --with-cxx-binding
50     --with-cxx-shared
51     --with-manpage-format=normal
52     --with-pkg-config-libdir=/usr/lib/pkgconfig
53     --with-shared
54     --with-versioned-syms
55     --with-xterm-kbs=del
56     --without-ada
57   )
59   cd $pkgname-$pkgver
60   ./configure "${configure_options[@]}"
61   make
64 package() {
65   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
66   install -vDm 644 $pkgname-$pkgver/COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
68   # fool packages looking to link to non-wide-character ncurses libraries
69   for lib in ncurses ncurses++ form panel menu; do
70     printf "INPUT(-l%sw)\n" "${lib}" > "$pkgdir/usr/lib/lib${lib}.so"
71     ln -sv ${lib}w.pc "$pkgdir/usr/lib/pkgconfig/${lib}.pc"
72   done
74   # some packages look for -lcurses during build
75   printf 'INPUT(-lncursesw)\n' > "$pkgdir/usr/lib/libcursesw.so"
76   ln -sv libncurses.so "$pkgdir/usr/lib/libcurses.so"
78   # tic and ticinfo functionality is built in by default
79   # make sure that anything linking against it links against libncursesw.so instead
80   for lib in tic tinfo; do
81     printf "INPUT(libncursesw.so.%s)\n" "${pkgver:0:1}" > "$pkgdir/usr/lib/lib${lib}.so"
82     ln -sv libncursesw.so.${pkgver:0:1} "$pkgdir/usr/lib/lib${lib}.so.${pkgver:0:1}"
83     ln -sv ncursesw.pc "$pkgdir/usr/lib/pkgconfig/${lib}.pc"
84   done