archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-convert-binhex / trunk / PKGBUILD
blob83f6279029e0f0c7992e73522a1ca253559eb249
1 # Maintainer: Giovanni Scafora <giovanni@archlinux.org>
2 # Contributor: Techlive Zheng <techlivezheng [at] gmail [dot] com>
3 # Contributor: Jakub FiĊĦer <mr [at] MikyMaus [dot] org>
4 # Contributor: Filip S. Adamsen <fsa [at] fsadev [dot] com>
6 pkgname=perl-convert-binhex
7 pkgver=1.125
8 pkgrel=11
9 pkgdesc="Perl module to extract data from Macintosh BinHex files"
10 arch=('any')
11 url="https://search.cpan.org/dist/Convert-BinHex/"
12 license=('PerlArtistic')
13 depends=('perl')
14 checkdepends=('perl-file-slurp' 'perl-test-most')
15 options=('!emptydirs')
16 source=("https://search.cpan.org/CPAN/authors/id/S/ST/STEPHEN/Convert-BinHex-$pkgver.tar.gz")
17 sha256sums=('513591b4be46bd7eb91e83197721b4a045a9753a3dd2f11de82c9d3013226397')
19 build() {
20   cd Convert-BinHex-$pkgver
21   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
22   make
25 check() {
26   cd Convert-BinHex-$pkgver
27   make test
30 package() {
31   cd Convert-BinHex-$pkgver
32   make DESTDIR="$pkgdir" install