archrelease: copy trunk to extra-x86_64
[arch-packages.git] / perl-text-patch / repos / extra-any / PKGBUILD
blob48477819fce69babcfa7b51b8b3a031c167a6596
1 # Maintainer: 
3 pkgname=perl-text-patch
4 pkgver=1.8
5 pkgrel=11
6 pkgdesc="Patches text with given patch"
7 arch=('any')
8 url="https://search.cpan.org/dist/Text-Patch"
9 license=('PerlArtistic' 'GPL')
10 depends=('perl')
11 checkdepends=('perl-text-diff')
12 options=('!emptydirs')
13 source=("https://search.cpan.org/CPAN/authors/id/C/CA/CADE/Text-Patch-$pkgver.tar.gz")
14 sha256sums=('eaf18e61ba6a3e143846a7cc66f08ce58a0c4fbda92acb31aede25cb3b5c3dcc')
16 build() {
17   cd Text-Patch-$pkgver
18   perl Makefile.PL INSTALLDIRS=vendor
19   make
22 check() {
23   cd Text-Patch-$pkgver
24   make test
27 package() {
28   cd Text-Patch-$pkgver
29   make DESTDIR="$pkgdir" install