archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pinentry / trunk / PKGBUILD
blob5130253e4b806313dcba03f36feb53d24bf14899
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Tobias Powalowski <tpowa@archlinux.org>
3 # Contributor: Gaetan Bisson <bisson@archlinux.org>
5 pkgname=pinentry
6 pkgver=1.2.1
7 pkgrel=1
8 pkgdesc='Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol'
9 url='https://gnupg.org/related_software/pinentry/'
10 arch=('x86_64')
11 license=('GPL')
12 depends=(
13   'glibc' 'ncurses' 'libcap' 'libassuan' 'libsecret' 'glib2'
14   libsecret-1.so libcap.so libncursesw.so libassuan.so libglib-2.0.so)
15 makedepends=('gtk2' 'qt5-base' 'gcr')
16 optdepends=(
17   'gtk2: gtk2 backend'
18   'qt5-base: qt backend'
19   'gcr: gnome3 backend'
21 backup=('etc/pinentry/preexec')
22 source=("https://www.gnupg.org/ftp/gcrypt/${pkgname}/${pkgname}-${pkgver}.tar.bz2"{,.sig}
23         'pinentry'
24         'preexec')
25 sha256sums=('457a185e5a85238fb945a955dc6352ab962dc8b48720b62fc9fa48c7540a4067'
26             'SKIP'
27             'af7c27139b20a7f1b9a227f3663abb21bb2b954523352b7844da27db1b0c1c86'
28             'f428f08d77f1f7830eadb8435af282a833fc13d8b623b122eefd9d3b628bef90')
29 validpgpkeys=(
30   'D8692123C4065DEA5E0F3AB5249B39D24F25E3B6' # Werner Koch (dist sig)
31   '6DAA6E64A76D2840571B4902528897B826403ADA' # Werner Koch (dist signing 2020)
32   'AC8E115BF73E2D8D47FA9908E98E9B2D19C6C8BD' # Niibe Yutaka (GnuPG Release Key)
35 build() {
36   cd "${pkgname}-${pkgver}"
37   ./configure \
38     --prefix=/usr \
39     --enable-pinentry-tty \
40     --enable-pinentry-curses \
41     --enable-fallback-curses \
42     --enable-pinentry-emacs \
43     --enable-pinentry-gtk2 \
44     --enable-pinentry-gnome3 \
45     --enable-pinentry-qt \
46     --enable-libsecret \
48   make
51 package() {
52   cd "${pkgname}-${pkgver}"
53   make DESTDIR="${pkgdir}" install
55   install -Dm 755 ../pinentry -t "${pkgdir}/usr/bin"
56   install -Dm 755 ../preexec -t "${pkgdir}/etc/pinentry"
59 # vim: ts=2 sw=2 et: