archrelease: copy trunk to extra-x86_64
[arch-packages.git] / rasqal / repos / extra-x86_64 / PKGBUILD
blobe79b654e0def0946f86b171c5180498b2e97c598
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Tom Gundersen <teg@jklm.no>
3 # Contributor: AndyRTR <andyrtr@archlinux.org>
4 # Contributor: Lawrence Lee <valheru@facticius.net>
6 pkgname=rasqal
7 pkgver=0.9.33
8 pkgrel=6
9 epoch=1
10 pkgdesc="A library handling RDF query syntaxes, construction and execution"
11 license=(LGPL2.1)
12 url="https://librdf.org/rasqal"
13 arch=(x86_64)
14 depends=(
15   glibc
16   libgcrypt
17   mpfr
18   pcre
19   sh
21 makedepends=(
22   gtk-doc
23   raptor
24   util-linux
26 provides=(librasqal.so)
27 source=(https://download.librdf.org/source/$pkgname-$pkgver.tar.gz{,.asc})
28 sha512sums=('05728682797470db9e51d156012e8fde9dec1554d107372faa11cbe6cdc3356e92386f4f8de6d7c41e3100b76f9b1c6809102a913829cddbd2ff29043c04d522'
29             'SKIP')
30 b2sums=('87bca86b2f0dceb0801f5a34dae9ae1f87d8a7d0dc1e03fdf04998a0d4885ed76be2719d3e01489a5510a26715bb093a75ce194cc42f3cedff88f64161d6a2fb'
31         'SKIP')
32 validpgpkeys=('F879F0DEDA780198DD08DC6443EC92504F71955A') # Dave Beckett <dave@dajobe.org>
34 prepare() {
35   cd $pkgname-$pkgver
36   autoreconf -fiv
39 build() {
40   local configure_options=(
41     --prefix=/usr
42     --disable-static
43     --enable-release
44   )
46   cd $pkgname-$pkgver
47   ./configure "${configure_options[@]}"
48   # prevent excessive overlinking due to libtool
49   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
50   make
53 check() {
54   make -k check -C $pkgname-$pkgver
57 package() {
58   depends+=(
59     raptor libraptor2.so
60     util-linux-libs libuuid.so
61   )
63   make DESTDIR="$pkgdir" install -C $pkgname-$pkgver
64   install -vDm 644 $pkgname-$pkgver/{ChangeLog*,README,NEWS} -t "$pkgdir/usr/share/doc/$pkgname/"