archrelease: copy trunk to extra-x86_64
[arch-packages.git] / yelp-tools / trunk / PKGBUILD
blob72a455e6b86e338451eb7f95c2a58446859e37cb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=yelp-tools
5 pkgver=42.1
6 pkgrel=1
7 pkgdesc="Collection of tools for building and converting documentation"
8 url="https://gitlab.gnome.org/GNOME/yelp-tools"
9 arch=(any)
10 depends=(yelp-xsl python-lxml itstool libxml2 docbook-xsl mallard-ducktype)
11 makedepends=(git meson)
12 license=(GPL)
13 _commit=fe5ff72ca46fba425143e5dc67d660703c86145f  # tags/42.1^0
14 source=("git+https://gitlab.gnome.org/GNOME/yelp-tools.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build -D help=true
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"