archrelease: copy trunk to extra-x86_64
[arch-packages.git] / yelp / trunk / PKGBUILD
blob9f5d675c9bb829788af10070e1ecb9a2610ad174
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=yelp
5 pkgver=42.2
6 pkgrel=2
7 pkgdesc="Get help with GNOME"
8 url="https://wiki.gnome.org/Apps/Yelp"
9 license=(GPL)
10 arch=(x86_64)
11 depends=(
12   bzip2
13   libhandy
14   libxslt
15   webkit2gtk-4.1
16   xz
17   yelp-xsl
19 makedepends=(
20   appstream-glib
21   autoconf-archive
22   git
23   itstool
25 optdepends=('man-db: View manual pages')
26 provides=(libyelp.so)
27 groups=(gnome)
28 _commit=9fd1a84e1eae23db21939ff76c7e96d5422d3b1a  # tags/42.2^0
29 source=(
30   "git+https://gitlab.gnome.org/GNOME/yelp.git#commit=$_commit"
31   no-gtk-doc.diff
33 b2sums=('SKIP'
34         'd6200723395292742105065baeab12ae308f8141069343c5ec79bcab10e4efbdea69ea9deffdcd7a2fb0c0ceeb886398b8b303ff750af1a79c38c64046664501')
36 pkgver() {
37   cd yelp
38   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
41 prepare() {
42   cd yelp
44   # Remove vestiges of docs build to allow building without gtk-doc
45   git apply -3 ../no-gtk-doc.diff
47   NOCONFIGURE=1 ./autogen.sh
50 build() {
51   local configure_options=(
52     --prefix=/usr
53     --sysconfdir=/etc
54     --localstatedir=/var
55     --enable-compile-warnings=minimum
56     --disable-static
57   )
59   cd yelp
60   ./configure "${configure_options[@]}"
61   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
62   make
65 package() {
66   cd yelp
67   make DESTDIR="$pkgdir" install
70 # vim:set sw=2 sts=-1 et: