1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Get help with GNOME"
8 url="https://wiki.gnome.org/Apps/Yelp"
25 optdepends=('man-db: View manual pages')
28 _commit=9fd1a84e1eae23db21939ff76c7e96d5422d3b1a # tags/42.2^0
30 "git+https://gitlab.gnome.org/GNOME/yelp.git#commit=$_commit"
34 'd6200723395292742105065baeab12ae308f8141069343c5ec79bcab10e4efbdea69ea9deffdcd7a2fb0c0ceeb886398b8b303ff750af1a79c38c64046664501')
38 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
44 # Remove vestiges of docs build to allow building without gtk-doc
45 git apply -3 ../no-gtk-doc.diff
47 NOCONFIGURE=1 ./autogen.sh
51 local configure_options=(
55 --enable-compile-warnings=minimum
60 ./configure "${configure_options[@]}"
61 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
67 make DESTDIR="$pkgdir" install
70 # vim:set sw=2 sts=-1 et: